Resolving error EN0ENT 34 when installing an NPM package

Recently was trying to install gulp-imagemin via NPM and ran into an error as NPM tried to install a dependency.

npm ERR! code ENOENT
npm ERR! errno 34

Ends up NPM was looking at my project’s .gitignore file and this caused a conflict. Adding a .npmignore file fixed the issue and the NPM install worked like a charm.

One thought on “Resolving error EN0ENT 34 when installing an NPM package

  1. Looks like a good way to remove duaiocptiln between build scripts and CI server. Manual editing of properties file for each release could probably be avoided if the job module-example release was scripted a bit. How is integration testing done for features and dev branches?

Leave a Reply

Your email address will not be published. Required fields are marked *